Systemanforderungen von Oxid


Bevor Sie den Oxid-Shop auf einem Server installieren können, sollten Sie sicherstellen, dass der den Anforderungen des Shop-Systems auch genügt. Neben einem PHP der Version 5.X wird eine MySQL-Datenbank benötigt, um Daten speichern zu können.

Für die Oxid-Community-Edition gelten die Systemvoraussetzungen:


Webserver:


  • Apache 1.3, besser mindestens 2.0
  • 100 MiB freier Webspace
  • Erweiterung mod_rewrite

PHP:

  • PHP 5.2.0, 5.2.6. Die Version 5.3.7 ist fehlerhaft und sorgt bei der Anmeldung für Probleme.
  • memory_limit: mindestens 14 MiB, besser 32. Für Shops mit komplexen Abfragen kann später sogar eine Erhöhung auf 128 MiB erforderlich sein.
  • allow_url_fopen
  • ini_set: erlauben
  • register_globals: Off

Für PHP werden ferner folgende Erweiterungen benötigt:

  • GD Lib 2
  • MySQL-Connector
  • bcmath
  • JSON
  • php-xml
  • libxml2
  • iconv
  • tokenizer
  • mbstring

Für die EE- und CE-Ausgaben von Oxid sowie immer dann, wenn mit Zend Guard verschlüsselte Erweiterungen installiert werden sollen, ist zusätzlich der Zend Guard Loader (früher: Zend Optimizer) für PHP zu sinstallieren.


Ein Gedanke zu „Systemanforderungen von Oxid

  1. Danke für die kurze und prägnante Übersicht.
    Wesentlich besser verständlich als die ganzen überladenen Informationsseiten dazu. Merci und schönen Abend

Kommentare sind geschlossen.